Saturday, January 3, 2009

Remember Certificate Exception extension for Firefox3

I submit a new add-on for Firefox3: Remember Certificate Exception.
https://addons.mozilla.org/en-US/firefox/addon/10246



RCE.xpi features:
Auto complete Firefox3 SSL certificate exception override on exceptionDialog.
Firefox3 introduced new 'Add Exception/BadCert Override' mandatory operations to bypass bad certificate exception.
It is much safer but inconvenient to do mass bypassing while doing development with self-signed certificates.
User wants a tool to auto complete add exception/badcert override operations.
RCE extension is a such kind robot which can:
- auto-click 'Or you can add an exception' link
- auto-click 'Add Exception' button
- auto-click 'Get Certificate' button
- auto-click 'Confirm Security Exception' button
- auto-reload ssl page
The idea of RCE.xpi came from solving my Selenium web automation testing ssl page blocking issue.
Please try badcert demo URLs inside http://kuix.de/mozilla/certwarndiscussion/proposal20061016/ with RCE extension.
Please read firefox3 security topic: http://www.smop.co.uk/blog/index.php/2008/03/25/firefox-3-security-madness/
WARNING: please disable RCE when you are going to browse untrusted websites to avoid phishing and mal-ware.

Screenshot:

27 comments:

  1. A very useful add on to get around a horrible procedure added to firefox3. I would love to see it grow. It would be perfect for our campus if it could be settup to run the proceedure only on certain domains or lists of web sites.

    ReplyDelete
  2. I tried to use this addon on FF3, as part of my selenium automation suite but still get the error.Here is the error description ---
    site:443 uses an invalid secuirty certificate.The certificate is not trusted because it is self signed
    The certificate is only valid for a id="cert_domain_link"
    title="localhost.localadmin"local
    (error code : sec_error_untrusted_issuer).
    When I manually click through this error, I get this firefox 3 secuirty exceptions which is not clicked through by RCE.
    Any help with this problem is very much appreciated.--- Chinmayi

    ReplyDelete
  3. Hi bro,

    Can you show me another add-ons like this for firefox2? I'm using firefox2 for my automation test. Thanks

    ReplyDelete
  4. First of all - great work! Very useful extension.

    I added this extension to my selenium RC testing and everything is working fine until the very last stage where after adding the exception, page needs to reload. I can see the standard dialogue box saying:

    "To display this page, the application must send information that will repeat any action (such as a search or order confirmation) that was performed earlier." Resent / Cancel

    Any ideas how to solve this problem?

    ReplyDelete
  5. I'll echo the first comment: great tool. It would be vastly improved (in my opinion) if it supported some method for specifying trusted sites or domains.

    ReplyDelete
  6. I have download RCE and installed the plugin, but dont see in the tools menu, how to use this tool?

    please respond rbasappa@gmail.com

    ReplyDelete
  7. I'm using this plug-in for quite some time with FireFox 3 and found very useful.

    When tried to install for FireFox 3.5, it says this plugin is for older version of FireFox.

    Any plans for supporting both versions? (FF 3.0 & 3.5)

    Thanks,
    Bala

    ReplyDelete
  8. Yes, we're having similar problems with Firefox 3.5. Any chance this addon will be updated?

    ReplyDelete
  9. Please update for FF 3.5! It's a great extension!

    ReplyDelete
  10. same problem with the "resent/cancel" confirm popup, when try to login to SSL protected website.

    ReplyDelete
  11. any chance this getting FF 3.5 support? I think I'd cry in appreciation if so! :D

    Thanks for the great extension!

    ReplyDelete
  12. Please, update this tool to use it in Firefox 3.5

    ReplyDelete
  13. Jerry, thanks for the super awesome add on, anytime line on when this will be supported for FF 3.5?

    ReplyDelete
  14. Adding my vote for 3.5 support...

    ReplyDelete
  15. I'm throwing in my plea to update for 3.5 as well. I use this addon at work every day, or used to, until some asshat updated FF to 3.5 on my machine, which broke the extension. I'd update it myself if I could figure out how.

    Thanks for all your hard work on this addon, Jerry. We really do appreciate it, hence why we are begging for an update :)

    ReplyDelete
  16. Support for 3.5 ? :-) Please Please Please! :-)

    ReplyDelete
  17. Hello all,

    I just installed RCE on Firefox 3.5 using this recipe:

    1: Use Internet Explorer to download

    http://releases.mozilla.org/pub/mozilla.org/addons/10246/remember_certificate_exception-0.8.0-fx.xpi

    and save it to disk.

    2: use a ZIP utility (I use free 7-zip) to open the .xpi file

    3: right-click install.rdf and choose Edit (F4)

    4: Find and replace em:maxversion text 3.1b2 with e.g. 3.9

    5: Close notepad and save - 7-zip will prompt you to update the .xpi archive - choose OK and close 7-zip

    6: Pull the .xpi file to an open Firefox 3.5 window, accept installation and restart Firefox 3.5.

    ReplyDelete
  18. I already installed the extension with the same trick suggested by Rasmus but replacing^the versión with 3.6.
    The extension installed but it wasn't working.
    Is it working for you Rasmus or just got installed?
    I'm giving it a try with 3.9...

    ReplyDelete
  19. Please update the extension for FF 3.5. Mozilla have chosen to introduce a new way of presenting the bad certs screen. The robot was extremely useful in my daily work, but they broken it.

    ReplyDelete
  20. on the mozilla extensions page, now RCE supports FF 3.5

    ReplyDelete
  21. would really want this plugin to work on linux and mac

    ReplyDelete
  22. Hi Jerry,
    Do you plan to make a mac osx version? Really would be great if you do...

    ReplyDelete
  23. Hi Jerry,
    Please make one for Mac OSX, it's really a great plugin

    ReplyDelete
  24. Hi,

    Any updates on compatibility with Firefox version 3.6?

    ReplyDelete
  25. Hi Jerry,

    Could you tell me where in the Firefox Profile for your extension is the "Enable RCE" (on/off) setting recorded?

    (Without going into details, the reason I want to know is because I want to set this programmatically, using a script, in the profile.)

    Thanks.

    ReplyDelete